Autore Topic: Offline non funzionante e Ver. PhP prima di aggiornare Dalla 3.3.0  (Letto 275 volte)

Offline energy

  • Nuovo arrivato
  • *
  • Post: 30
    • Mostra profilo
Salve a tutti,Ho un sito con la vecchia versione 3.3.0,   PHP v. 5.5.38,  Server MySql5.0.92
volevo aggiornare il sito con la funzione automatica ma avevo delle impostazioni Php da aumentare,
Codice: [Seleziona]
upload_max_filesize dovrebbe essere 32Mb o superiore post_max_size   stesso valore di upload_max_filesizePoi pero' ho visto che il form per far andare il sito Offline, non funziona, cioe' su Configurazione Globale clicco su SI, e premendo Salva, il form riporta ancora il pallino su No, ed il sito Non va effettivamente OffL,   perché? Idem su Server -> Rapporto errori, se voglio mettere Massimo (dal Default, il menu' torna come prima una volta salvato!)

L'altro problema e' la versione PHP, che versione mi serve per aggiornare automaticamente alla 3.6.5 (come obbligatorio)
se dal pannello dell Hosting aumento la versione sopra la 5.5.38 (mi servirebbe installare anche Akeeba che richiede una 5.6 pero')  il sito non funziona piu' sia in Admin sia pubblico, riportando un errore:"Error displaying the error page: Application Instantiation Error: Could not connect to MySQL."     
 Cosi' sono tornato indietro alla 5.5.38 e tutto funziona come prima, o meglio, tutto meno che il Sito Offline insieme alle altre impostazioni della Configurazione Globale.   
  Il configuration.php dalla schermata dei Permessi Cartelle, cmq risulta Non scrivibile, che la guida per l'aggiornamento del sito indica come corretta impostazione.
Come procedo?   
Cache del sito disabilitata,   
Pulizia Cache fatta     
Estensioni per la mia versione J, aggiornate
Grazie Mille
« Ultima modifica: 15 Mar 2019, 22:47:40 da energy »

Offline emerenziano

  • Esploratore
  • **
  • Post: 111
  • Sesso: Maschio
    • Mostra profilo
Re:Offline non funzionante e Ver. PhP prima di aggiornare Dalla 3.3.0
« Risposta #1 il: 15 Mar 2019, 20:49:05 »
Hai verificato in configuration.php se il server, il nome del DB e l'utente dello stesso sono corretti ? L'errore che hai indicato dice che non puoi accedere al DB e questo può essere solo per un'errata configurazione (vedi sopra) o per mancanza di permessi dell'utente, cosa che puoi verificare con il phpmyadmin di Cpanel.
Se non va così devi chiedere all'hosting in quanto potrebbe essere un problema di errata installazione di PHP 5.6.

Offline energy

  • Nuovo arrivato
  • *
  • Post: 30
    • Mostra profilo
Re:Offline non funzionante e Ver. PhP prima di aggiornare Dalla 3.3.0
« Risposta #2 il: 15 Mar 2019, 22:54:42 »
Emerenziano, grazie per la risposta,   
  ho aggiornato il Topic iniziale, prima di vedere quel problema, io aggiornerei, ma devo prima metterlo Offline il Sito,   
poi capire se la 3.3.0 puo' avere Php 7 e modificarla dal pannello dell'Hoster
In piu' c'e' l'installazione di Akeeba che richiede Php almeno 5.6

Online tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29928
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:Offline non funzionante e Ver. PhP prima di aggiornare Dalla 3.3.0
« Risposta #3 il: 16 Mar 2019, 00:12:14 »
Mai modificare il post iniziale dopo invio salvo errori da correggere subito. Nessuno dopo averlo letto una volta lo rileggerà e confonderai solamente.
Poi non capirò mai chi dice non posso aggiornare, se non potete farlo avete sbagliato in partenza meglio rinunciare a fare e seguire siti.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline energy

  • Nuovo arrivato
  • *
  • Post: 30
    • Mostra profilo
Re:Offline non funzionante e Ver. PhP prima di aggiornare Dalla 3.3.0
« Risposta #4 il: 16 Mar 2019, 12:31:31 »
Grazie per la risposta Tom,Dalla post di Emerenziano ho capito che non mi ero spiegato bene e mancava qualcosa, avendo risposto solo lui ho pensato di aggiornare per una chiarezza del problema anche a chi arrivava dopo.
 
Io voglio aggiornare eccome, purtroppo per alcuni problemi la versione di quel sito e' rimasta indietro.

Offline emerenziano

  • Esploratore
  • **
  • Post: 111
  • Sesso: Maschio
    • Mostra profilo
Re:Offline non funzionante e Ver. PhP prima di aggiornare Dalla 3.3.0
« Risposta #5 il: 16 Mar 2019, 18:41:44 »
Al di là di quanto ho scritto in precedenza, altre idee non me ne vengono. Per sapere se la tua installazione di Joomla è compatibile con PHP 7.x ed il server usa Cpanel è molto semplice fare il passaggio con "Gestione MultiPHP" azione che è assolutamente reversibile.Sul fatto che non riesci a mettere offline il sito, l'aggiornamento si fa in 5 minuti, per cui a meno che non sia un sito strategico puoi anche farlo con il sito in linea.

Offline radu81

  • Esploratore
  • **
  • Post: 58
  • Sesso: Maschio
    • Mostra profilo
Re:Offline non funzionante e Ver. PhP prima di aggiornare Dalla 3.3.0
« Risposta #6 il: 18 Mar 2019, 00:01:02 »
... su Configurazione Globale clicco su SI, e premendo Salva, il form riporta ancora il pallino su No, ed il sito Non va effettivamente OffL,   perché? Idem su Server -> Rapporto errori, se voglio mettere Massimo (dal Default, il menu' torna come prima una volta salvato!)
Questo è un problema di permessi, con il file manager del tuo cpanel, oppure con un software tipo Filezilla fai tasto destro sul file configuration.php e scegli "File Permission" e impostalo a 644.
Oppure puoi modificare il file configuration.php
Codice: [Seleziona]
public $offline = '0';impostanto 1 invece di 0

Offline energy

  • Nuovo arrivato
  • *
  • Post: 30
    • Mostra profilo
Re:Offline non funzionante e Ver. PhP prima di aggiornare Dalla 3.3.0
« Risposta #7 il: 18 Mar 2019, 10:08:41 »
Questo è un problema di permessi, con il file manager del tuo cpanel, oppure con un software tipo Filezilla fai tasto destro sul file configuration.php e scegli "File Permission" e impostalo a 644.
Radu grazie per la risposta,   
in quel modo non basta, ancora non salva i settaggi, incluso il reCaptcha come standard. 


Oppure puoi modificare il file configuration.php
Codice: [Seleziona]
   public $offline = '0';impostanto 1 invece di 0
 

Provero' cosi' intanto

Per sapere se la tua installazione di Joomla è compatibile con PHP 7.x ed il server usa Cpanel è molto semplice fare il passaggio con "Gestione MultiPHP" azione che è assolutamente reversibile.
Cos'e' MultiPHP?  Il pannello del server per sceglierne la versione o altro?
Ora ho la 5.5.38, che avevo settato dal suddetto pannello, come versione basta come minima nelle specifiche per Joomla 3.6.5,   
che e' quella che potro' installare automaticamente dalle impostazioni.

Per il resto sto aspettando l'Hoster per impostare MySql almeno alla 5.1 ed InnoDB compatible

Offline emerenziano

  • Esploratore
  • **
  • Post: 111
  • Sesso: Maschio
    • Mostra profilo
Re:Offline non funzionante e Ver. PhP prima di aggiornare Dalla 3.3.0
« Risposta #8 il: 18 Mar 2019, 20:48:07 »
MultiPHP è l'applicazione di CPanel che consente di passare da una versione all'altra di PHP con un click. Insieme di solito è presente un editor di php.ini per le variazioni che possono rendersi necessarie con la nuova versione.

 

Host

Torna su