Back to top

Autore Topic: [RISOLTO] Articoli senza formattazione...  (Letto 5802 volte)

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
[RISOLTO] Articoli senza formattazione...
« il: 07 Apr 2008, 15:01:00 »
Ho appena reinstallato joomla 1.5.2 da capo, funziona tutto tranne la formattazione degli articoli.
Ho dentro solo i tre plugin di base, riesco a dare la formattazione sia come admin che come utente, ma dopo aver salvato l'articolo torna come prima cioè senza formattazione!

Ho copiato i settaggi di altri siti dove tutto funziona, ho provato diverse combinazioni di settaggi e anche diverse combinazioni dei tre editor di base attivandoli e disattivandoli.
In preferenza articoli ho inserito admin in white-list e la casella no html  non è spuntata...
Qualche idea in più?
grazie...

« Ultima modifica: 10 Apr 2008, 11:23:12 da 56francesco »
(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re: Articoli senza formattazione...
« Risposta #1 il: 07 Apr 2008, 16:34:45 »
Continuando a smanettare devo previsare:
a- come "admin" scrivo l'articolo con editor abilitato gli do la formattazione  lo salvo e lo visualizzo come una polpetta senza formattazione, funziona "leggi tutto"
b- come admin con l'editor non posso più incollare ma solo scrivere.
c- come admin con "no editor" posso incollare e salvare articoli già formattati  ma se vado in modifica li vedo nello stesso editor come polpette, cioè senza formattazione.

e- come utente non posso più incollare con editor abilitato, incollo con "no editor"  come sopra quindi...
f- se rileggo gli articoli li vedo sempre come polpette PERO'  se li riprendo in modifica  (come utente) la formattazione ci sta ancora.

Dove sta la soluzione?  eppure ho controllato come sopra con altri siti 1.5.2 (tre) le configurazioni di tutti i parametri che ho potuto.....
Nella prima installazione, quella cancellata, con il medesimo template e gli stessi editor  non avevo questo problema..

PS
gli articoli copiati sono gestiti con openoffice, ma scrivendoli ex novo sia come user che come admin non cambia niente.....
 :'( :'( :'( :'(
« Ultima modifica: 07 Apr 2008, 16:38:24 da 56francesco »
(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re: Articoli senza formattazione...
« Risposta #2 il: 08 Apr 2008, 11:40:57 »
In attesa si scoprire cosa:

Mi sono chiesto se dipendesse dal template, se cioè il formato del template prevalesse (css?) sulla formattazione mia (html?)
per saperlo ho fatto così:

1- impostato il template predefinito (runmilkway) originale di joomla
2- cancellato la cache del pc, chiuso il browser e riaperto di nuovo
3- scritto un articolo di prova come admin
4- verificato che in anteprima l'articolo si visualizzasse regolarmente...
5- inviato l'articolo
6- letto l'articolo nel sito pubblicato con il template runmilkway 
tutto come prima,  l'articolo si visualizza si ma senza alcuna formattazione, quindi non dipende dall'uso di un particolare template.

A risentirci alla prossima puntata...

se vi vengono idee sarei bel lieto di prenderle in considerazione, grazie..
Mi posso fare sempre tutto io ;-)
 ;D ;D ;D ;D
(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re: Articoli senza formattazione...
« Risposta #3 il: 08 Apr 2008, 16:18:34 »
Chi la dura la vince  (toccoferro)
 :D :D :D :D :D :D
dunque, ho riflettuto che quando sopra doveva essere evidentemente un problema di configurazione, già ma di cosa?
Cosa era configurato malamente?
Il joomla? l'editore? gli articoli? oppure qualcosa altro?
Insomma per non farla lunga:
La versione 1.5.2 ha aggiunto in configurazione articoli dei filtri, c'è un bug evidentemente perchè in origine è tutto vuoto, si può selezionare e deselezionare una categoria utente ma una volta selezionato una pallina (provate e verificate) poi non potete più deselezionare la scelta,  nel mio caso dopo aver provato e non potendo deselezionare tutto avevo optato per "administrator" e per "white list" 
Tale scelta mi impedisce la formattazione come admin (non si capisce perchè?)  perchè ne da pannello ne da utente admin riesce più a salvare la formattazione degli articoli, pur non avendo selezionato "NO HTML" 
Sospettando qualcosa di simile ho creato un nuovo utente con i poteri di editore e ora (toccoferro)  la formattazione funza!!!!!!!
 :D
Bhe.. magari servirà per qualcun altro, vuoi che prima o poi qualcuno non vada a curiosare tra il filtro come ho fatto io?

Ciao
Ps
se volete verificare e se lo è riferire il bug a chi di dovere. anticipo che non sarò geloso della mia scoperta e non vi chiederò le rojalty.
 ;D
(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

Offline ste

  • Instancabile
  • ******
  • Post: 8774
  • Sesso: Femmina
    • Mostra profilo
Re: Articoli senza formattazione...
« Risposta #4 il: 08 Apr 2008, 18:47:34 »
Ciao 56francesco, grazie per aver postato le varie verifiche che hai fatto per risolvere il problema.
Casomai è meglio impostare il filtro agli utenti semplici Registered, altrimenti limiti te stesso...
TTI - Team Traduzione Italiano di Joomla.it - Guide su Joomla

Offline 56francesco

  • Fuori controllo
  • *
  • Post: 29585
  • Sesso: Maschio
    • Mostra profilo
Re: Articoli senza formattazione...
« Risposta #5 il: 09 Apr 2008, 09:53:46 »
Ciao 56francesco, grazie per aver postato le varie verifiche che hai fatto per risolvere il problema.
Casomai è meglio impostare il filtro agli utenti semplici Registered, altrimenti limiti te stesso...

Grazie a te, anzi a voi, sto apprendendo molto qui.
;-)
(uso XP perchè win98 non si installa) 
PS: non sono un dipendente dello sbonzor quindi è necessario un "per favore" alla richiesta e un "grazie" alla risposta, sempre! PPS: non scrivo mai per primo in MP, in caso contrario chiedimi una conferma, Grazie.

 



Web Design Bolzano Kreatif