Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - Guadagnonelweb

Pagine: [1] 2 3 4
1
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 14 Mag 2012, 12:28:49 »
Ma č normale che, lasciando impostato come phpmail, cancello nome utente e psw, salvo e me li ritrovo nuovamente scritti?  :o

Edit: adesso ha accettato la cancellazione ;)


2
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 14 Mag 2012, 12:26:37 »
Grazie di cuore...adesso verifico e provo, poi ti aggiorno  ;)

3
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 14 Mag 2012, 11:42:33 »
Questa la configurazione attuale:

Funzione mail: phpmail
Percorso sendmail: /usr/sbin/sendmail
Auth SMTP: no
Sicurezza SMTP: SSL
Porta SMTP: 25
Host SMTP: localhost

poi nome utente e psw...

4
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 12 Mag 2012, 19:59:26 »
Davvero non capisco a questo punto il problema, devi usare o una o l'altra č inutile che pubblichi tutte e due. Se hai detto che quello di fox funziona lascia quello e basta, non serve confrontarli, tu hai detto che pubblicando il componente fox usciva invece quello standard, ma  vedendo le immagini non č proprio cosė.


Tom su questo punto siamo d'accordo...ne devo usare uno dei 2, il problema č che entrambi non vanno!


Il componente nativo sembra funzionare, nel senso che dā anche il messaggio di email regolarmente inviata, ma poi di fatto l'email non arriva nč al mittente nč al destinatario...


e qui ho provato con fox contact...


Fox contact anche se, apparentemente ben configurato, non mi viene visualizzato nella pagina dedicata ai contatti...anche se disabilito, sospendo, cancello il componente nativoo non mi viene comunque visualizzato e nella pagina dei contatti mi esce la scritta 'errore. contatto non trovato'.


Ho messo le immagini di entrambi gli elementi solo nella speranza che vi saltasse all'occhio qualche impostazione che a me sta sfuggendo e che, di fatto, non mi fa avere un banalissimo form per i contatti nel sito...mi č indifferente usare l'uno o l'altro, basta che funzioni!

5
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 12 Mag 2012, 18:09:52 »
Allora ecco riporto qui qualche schermata che spero possano agevolare:


Dettaglio delle opzioni per il componente fox contact:








Dettaglio da gestione estensioni, sia per il componente nativo che per fox contact:














Dettaglio componente nativo:




6
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 12 Mag 2012, 16:54:44 »
Le immagini che hai postato per la voce foxcontact non sono quelle del componente nativo, sono proprio del componente fox, anche se alcune parti sono simili o addirittura uguali.


Sė lo so, se vuoi dimmi che schermate ti possono interessare per cercare di capire dove sta l'inghippo...in quella stessa schermata c'č tutta la parte di destra con tutte le altre impostazioni che č possibile settare in fox contact.




7
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 12 Mag 2012, 10:34:56 »
Peccato.
Allora ripristina il file modificato e segui le indicazioni di Tom, se Fox ti funzionava usalo, vedo che ora sai abbinare una voce di menų al componente, non devi far altro che Menų->Nuovo->Seleziona... ti si apre il forma e a Contatti scegli quello che ti aggrada...
by  ;)


Il mio problema č che anche impostando correttamente le cose e collegando la voce di menų al componente fox contact, nella pagina dedicata ai contatti mi visualizza sempre il componente nativo di joomla...ora, ad esempio, ho sospeso il componente nativo e nella pagina dei contatti mi vusalizza la scritta 'Errore. Contatto non trovato' e non fox contact!


Dove sto sbagliando?  :o

8
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 12 Mag 2012, 10:06:41 »
provato ma niente, non funziona!

9
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 12 Mag 2012, 09:50:19 »
Il mio suggerimento era per il componente CONTATTI nativo in Joomla, vedo che tu hai indirizzato la voce di menų a Fox!  :-\


Ah ok, nn ci avevo capito una cippa! Allora provo a eliminare la voce di menų relativa a fox contact e vediamo se funziona  ;)

Quindi comunque mi confermi che cosė come č impostato dovrei visualizzare il componente fox contact, giusto?

10
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 11 Mag 2012, 18:16:58 »

 :-\   Semplice no!?


Dai che puoi farcela.... :D



Ho fatto  8)  Incredibile???  ;D


Perō la cosa non č comunque cambiata di una virgola...ho sempre il componente nativo.... :-\


Questa č la schermata con le impostazioni della voce di menų che ho creato per fox contact..



Dettaglio:







Ora quando mi dite di indirizzarla al componente contatti credo di averlo fatto stando a quanto vi sto mostrando o no????  :o

11
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 11 Mag 2012, 17:56:13 »
Dunque...non conoscendo la tua esperienza comincio da un certo livello... tomtomeight ti segue molto bene su quella direttiva, io cercherō di spiegarti come agire sul file indicato.
Allora avrai certamente il programma di File transfert detto FTP, cerca nella root questo file: /libraries/phpmailer/phpmailer.php
aprilo con uno dei tanti programmini free tipo NOTEPAD++ e alla riga 709 trovi la stringa:


if ($this->Sender != '' and !ini_get('safe_mode')) {


devi semplicemente aggiungere i caratteri in rosso:


if ($this->Sender != '' and !ini_get('safe_mode') and 1>1) {


Salvi e ripubblichi nella stessa posizione.


 :-\   Semplice no!?


Dai che puoi farcela.... :D


ps. naturalmente lasci la configurazione di default per il componente nativo dei contatti. Poi crei una nuova voce di menų e lo indirizzi al componente contatti o al singolo contatto....


Il piedistallo per il mezzobusto per te e Tom č quasi pronto... ;D  Siete veramente gentilissimi e pazienti, infinitamente grazie  :-*


Ora provo a vedere con le precise info che mi hai dato...e vediamo che succede, quindi il componente nativo lo lascio nello stato pubblicato, giusto?

12
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 11 Mag 2012, 17:54:05 »
E' quė che non ti seguo, se hai creato una voce di menų per il componente fox contact, cosa c'entra la home. Semmai hai attivato il modulo e lo hai associato alla home. Ma sono due cose diverse.


No in pratica nei vari tentativi che ho fatto (sbagliando s'impara  ;) )ho creato il componente e gli ho messo SI alla voce PAGINA PREDEFINITA a quel punto andando a vedere il sito me lo sono ritrovata caricata in home page :o  Se poi sono pure riuscita a fare una cosa impossibile, non ho idea.... 8)

13
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 11 Mag 2012, 14:39:12 »
Ecco adesso capisco di pių dopo aver letto anche l'altro post. Lascia stare l'override perchč non devi fare nessuna modifica. Per sostituire un estensione con un altra, nel caso di componente si associa alla stessa voce di menų il componente che vuoi sostituire, nel caso di un modulo, si spubblica il primo e si pubblica il secodo nella stessaposizione. Adesso non conosco se il fox contact č un modulo oppure un componente, perō se segui quanto sopra č facile scambiare i due.


Ok grazie...comunque fox contact č settabile in ambo i modi, sia come modulo che come componente..io l'ho creato come componente e sono convinta di aver fatto esattamente quello che mi indichi tu, a meno che non debba abilitare qualcos'altro che al momento mi sfugge  :P


Magari se sei cosė gentile da dirmi come fai ad associare il componente ad una voce di menų...io son convinta di averlo giā fatto o meglio, fox contact ti dice di creare una nuova voce di menų e scegliere la sua specifica, quindi + facile di cosė  ;D  ed ho chiamato la voce esattamente contatti! E l'ho creata correttamente visto che quando l'ho erroneamente messa nella home ha funzionato perfettamente....


...e da qui il mio dubbio? come faccio a far capire a joomla che mi deve usare fox contact e non il precaricato? cosa sto omettendo?  :-\

14
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 11 Mag 2012, 14:05:04 »
Non capisco cosa c'entri l'override, se invece di utilizzare una componente ne utilizzi un altra che problema hai, anzi dici pure che ti funziona allora lascia stare il componente nativo ed utilizza quello che ti funziona.


Mi sto spiegando male, cerco di rimediare...fox contact non me lo visualizza nella pagina dove dovrebbe! Continua a visualizzarmi quello integrato! Se lo disabilito ha comunque la precedenza e anzichč mettermi fox contact mi esce la scritta 'contatto non trovato'.


La discussione nativa la trovi qua: [size=78%]http://forum.joomla.it/index.php/topic,162833.0.html[/size] poi cercando altri aiuti son capitata qui e mi ci sono accodata...




15
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 11 Mag 2012, 12:26:29 »

Anch'io ricevo normalmente la posta dal server utilizzato poi per installare J2.5.4 eppure le e-mail dai contatti non partivano e senza nessun errore se settato su phpmail.
Modificando la stringa nel file phpmailer.php suggerito da Francesco tutto č andato bene.
Per gli overrides, se dici di essere alle prime armi, č meglio informarti bene prima sui procedimenti!  :)


Ti ringrazio per aver riportato la tua esperienza...anche io sono titubante sull'uso dell'override... ::)

Potresti gentilmente spiegarmi meglio la modifica da apportare nella stringa nel file phpmailer.php, se non ti chiedo troppo se potessi indicarmi la cosa passo passo. Mi consigli comunque di impostare su phpmail...

Grazie mille soprattutto per la gentilezza :)

16
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 11 Mag 2012, 09:03:37 »
Non c'č nulla da capire, non usi quello di joomla e pubblichi fox.


E qui invece per me casca l'asino...nel senso che io invece vorrei capire perchč diavolo nella pagina contatti del mio sito non mi pubblichi fox contact e mi resti sempre quello predefinito di joomla...


Ho provato a:


- mettere in sospeso i contatti di joomla e nella mia pagina mi esce la scritta 'contatto non trovato'
- ho disattivato i contatti di joomla e mi esce errore 404 caricando la pagina
- ho (erroneamente) impostato come predefinito il componente fox contact e me lo sono ritrovata caricato in home page...ma siccome non tutto il male vien per nuocere ho avuto almeno modo di vedere e constatare che il tutto funzionava (la mail arrivava correttamente sia al mittente che al destinatario)


Un altro moderatore mi ha suggerito di ricorrere all'override...ma siccome io sono alla mia prima esperienza con joomla e sono pure piuttosto imbranata  :P  devo avere qualche minuto (e anche qualcuno pių di qualche) di completa tranquillitā senza le belvette (leggasi le mie bimbe  ;D ) per provare...


Fox contact č veramente per babbei ed il fatto che messo in home mi ha funzionato significa che l'ho settato bene...ma allora dove sto sbagliando? Concordi anche tu con la necessitā di dover ricorrere all'override oppure hai da suggerirmi qualcosa che, pur nella sua semplicitā, mi sfugge?


Ti ringrazio

17
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 10 Mag 2012, 22:14:43 »
Beh ragazzi, la soluzione č stata data poco sopra, come mai aggiungete senza leggere!?


Forse avete attuato la soluzione data e non vi funziona lo stesso?


Personalmente ho provato le soluzioni che mi son state date e non han funzionato...che non sia un problema di server sono sicura visto che su quel'account ricevo regolarmente la posta...


vorrei capire come sostituire fox contact ai contatti predefiniti di joomla...e mi han suggerito l'override, ma devo ancora provare


18
Joomla! 1.6/1.7/2.5 / Re:Modulo contatti non funziona
« il: 10 Mag 2012, 12:41:40 »
Mi aggiungo qua...io ho la versione 2.5.4 eppure il modulo contatti non mi funziona...non mi dā alcun errore, mi esce il messaggio di ringraziamento per l'invio ma l'email non arriva nč al mittente (in copia) nč al destinatario.


Le impostazioni del server sono ok visto che comunque ricevo su quell'account tutto il resto della posta :)


Ho anche provato a mettere fox contact perō vien sempre fuori il modulo contatti integrato in joomla >:(

19
Devi creare un nuovo menu e nella scelta della tipologia lo devi associare a fox contact, trovi anche tutti i parametri per impostarlo come meglio credi.


Mi intrufolo visto che parli di Fox contact...io ho fatto esattamente cosė perō nella pagina contatti continua a visualizzarmi quella integrata in joomla. Uso la versione di joomla 2.5.4.


Mi hanno detto che dovrei fare l'override, ma non so bene come devo fare... aiutino?

20
No scusami Francesco non ho capito cosa mi sarei cercata...io sto solamente cercando di far funzionare un qualcosa che al momento non fa quel che dovrebbe...se poi ho fatto o detto strafalcioni, chiedo scusa, ho ammesso subito la mia assoluta ignoranza!


Che poi non sia un problema legato all'hosting č chiaro perchč su quell'account ricevo regolarmente la posta ed il modulo fox contact funziona...


Comunque scusa se ti ho fatto perdere tempo, cercherō tra le tante risposte quella che fa al caso mio. Grazie per il tempo che mi hai dedicato.

Pagine: [1] 2 3 4
Host

Torna su