Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - dacdam

Pagine: 1 2 3 [4] 5 6 7 ... 10
61
Sviluppo / Re:Problema con JRoute
« il: 01 Giu 2010, 14:49:18 »
In effetti il problema si presenta solo con il SEF attivo.
Ho fatto un dump di $option ed ho visto che a posto.
Il fatto che aggiungendo
Codice: [Seleziona]
?Itemid=2 all'indirizzo della home, le cose cominciano a funzionare, per quello sono convinto che il problema stia l...

62
Sviluppo / Re:Problema con JRoute
« il: 01 Giu 2010, 12:29:04 »
Non riesco comunque a farlo funzionare.

Ecco cosa ho fatto:
1- Ho dichiarato global $Itemid e, con un var_dump, ho controllato che fosse valorizzata correttamente. Tutto ok: anche per l'home page (dove nell'indirizzo non compare Itemid) assume il valore corretto in base all'id del punto di men.

2- Ho settato il suo valore nella request:
Codice: [Seleziona]
JRequest::set(array('Itemid'=>$Itemid));
Ciononostante, usando JRoute per valorizzare i link alle altre view del componente, non mette &Itemid nell'url generato.... con i conseguenti problemi per cui ho postato...

Non capisco dove JRoute vada a reperire il valore di Itemid e come decida di inserirlo negli url generati.

Forse conviene che apro la classe JRoute  e mi metto a cercare...

63
Sviluppo / Re:Componete e parametri personalizzati
« il: 31 Mag 2010, 12:36:51 »
Chiedo perdono se riapro questo post ormai un p vecchiotto...
Per io credo di sapere come mai l'Itemid non valorizzato: perch il componente collegato alla voce di men predefinita!

Anche io st impazzendo cercando di gestire l'Itemid quando ci si trova nella home page del sito.... ma non ne vengo fuori!

Questa cosa d diversi problemi, tra cui malfunzionamenti in JRoute... qualcuno avrebbe qualche dritta da darmi su come si gestisce l'Itemid quando si sviluppa un componente che si vuole usare come home page ?

Grazie e scusate ancora per la riapertura.

Caio.

64
Sviluppo / Itemid della home page
« il: 31 Mag 2010, 09:45:55 »
St avendo problemi con un mio componente che ho utilizzato come home page di un sito.
Il fatto che la home page non ha l'itemid nell'url e quindi i link generati dal mio componente per accedere alle sue sotto gestioni risultano errati.

Visto cos credo che si tratti di un problema molto comune tra gli sviluppatori, ma non trovo materiale in rete... qualcuno si scontrato con questa problematica e magari s darmi qualche dritta ?

Grazie per l'aiuto,
Ciao!

65
Sviluppo / Re:Problema con JRoute
« il: 30 Mag 2010, 20:27:08 »
Altre osservazioni: il componente richiamato come pagina iniziale ha pi view ed ho notato che, navigando da una all'altra di queste, lo stato del men attivo non viene impostato correttamente. Per intenderci: nessuna delle voci del men viene evidanziata come corrente.
Ho provato ad aggiungere
Codice: [Seleziona]
&Itemid=2 (2 l'id della voce che impostata come principale del sito) all'url ed ho notato che la voce corrente viene impostata correttamente....

Non che questa mancata gestione dell'itemid la causa del problema per cui ho aperto il post ?
Qualcuno s dirmi come fare passare l'itemid quando si accede alla pagina principale del sito ?

66
Sviluppo / Re:Problema con JRoute
« il: 30 Mag 2010, 12:01:32 »
Mi sono accorto che, per la pagina principale, nell'url non compare l'itemid... pu essere per quello ?

67
Sviluppo / [RISOLTO] Problema con JRoute
« il: 30 Mag 2010, 11:47:55 »
In un componente che ho chiamato "wsblog" Con questa istruzione:
Codice: [Seleziona]
$linkCrea = JRoute::_('index.php?option='.$option.'&task=crea');Ottengo querto URL:
Citazione
/index.php/component/wsblog/crea
Con quel "component" di mezzo le cose non funzionano....

Il problema ce l'ho solo se la pagina impostata come predefinita del sito e se ho attivato i friendly url nel pannello di amministrazione.

Ho un router.php, ma anche provando a toglierlo le cose non cambiano....

Come mai mi aggiunge quel "component" ???

68
Sviluppo / Re:[RISOLTO] Mettere il sito offline da frontend.
« il: 28 Mag 2010, 13:50:34 »
Hai ragione, non il massimo, solo che vorrei fare un sito dove l'utente con funzioni di admin non entri nell'amministrazione ed abbia a disposizione solo alcune possibilit fornite dal superadmin (che sarei io).

Grazie per la risposta.
Ciao.

69
Sviluppo / [RISOLTO] Mettere il sito offline da frontend.
« il: 28 Mag 2010, 11:27:24 »
In un componente, vorrei permettere all'utente amministratore di mettere il sito off-line da front-end.
Ho visto che il reperimento di un valore dalla configurazione si f con getCfg di Japplication, ma come faccio a modificarlo ed a salvare il nuovo stato ?

Grazie a tutti, ciao.

70
Hai ragione, avevo sbagliato completamente titolo per il post..  :-[

Comunque adesso funziona.

Grazie.

71
Sviluppo / Re:Aggiungere una classe all'editor.
« il: 21 Apr 2010, 14:33:01 »
Non f al caso mio perch mi serve per controllare che la textarea non sia vuota.
Per usare
Codice: [Seleziona]
JHTML::_('behavior.formvalidation');
sono obbligato ad aggiungere la classe "required" al campo...
Ho provato ad eseguire il controllo con javascript usando
Codice: [Seleziona]
form.testo.value == "" (dove testo il nome della textarea associata al tinyMCE), ma non funziona: dice sempre che vuoto.
Come si controlla via javascript se la textarea associata all'editor predefinito vuota ?

72
Ho un componente dove, ad un certo punto, emetto l'editor predeinito. Uso questa istruzione:
Codice: [Seleziona]
$editor->display('testo',$row->testo,'500','300','100','100',false,array("class"=>"required"))
L'ultimo parametro un array associativo dove cerco di passare la classe required all'editor... per non funziona, qualcuno s dirmi perch ?
Ciao!

73
Gestione Forum / Lista badwords
« il: 23 Mar 2010, 16:04:42 »
Ciao ragazzi.
Ho cercato un bel p in rete, ma non trovo una lista di badwords da copiare per non dovermele inserire tutte manualmente....
Non c' niente del genere in giro ?

Ciao.

74
Joomla! 1.5 / Re:xmap e contenuti non linkati a men
« il: 13 Mar 2010, 16:53:04 »
Citazione
bhe... qui siamo all'abc davvero

 ??? Non sono d'accordo... e suona un p come uno sfott.

Citazione
cos come l'abc e anche la condivisione in questo forum
Mi sembra un'accusa e mi dispiace, se ritenessi che il mio lavoro ha i requisiti per essere condiviso lo farei. Al momento funziona e basta, ben diverso da qualcosa di parametrico ed utilizzabile da chiunque, sicuramente non faticherai a capirlo e mi permetto di presumere che come amministratore tu voglia per questo sito solo estensioni sicure e sviluppate da persone che non siano alle prime armi.

Ho l'impressione che con questa discussione siamo pi sul polemico che sul costruttivo, se per te va bene direi che pu bastare.

Per me e per chi leggesse alla ricerca di informazioni (ammesso che non sia l'unico a non sapere come soddisfare l'esigenza che ha dato origine al tread) rester comunque utile sapere che ci si deve informare sullo sviluppo di estensioni per xmap. Lasciate perdere i plugin di joomla per questo scopo perch il componente xmap, almeno fino alla versione 1.2.6, non supporta il pattern observer implementato da joomla ed utilizzabile estendendo la classa Jplugin.

75
Joomla! 1.5 / Re:xmap e contenuti non linkati a men
« il: 13 Mar 2010, 14:36:59 »
No, non voglio che altri utenti evoluti scrivano il plug-in per me, lo voglio scrivere io. Da quello che mi dici sembra che ci si possa interfacciare ad xmap utilizzando un plug-in, se sai indicarmi dove trovare documentazione in merito a questa interazione te ne sarei grato.
Per quanto riguarda la condivisione del componente, un'idea che mi piace, ma per ora non ancora pronto:
- Non sono riuscito ad implementare il pattern MVC, non ho compreso bene la guida che sto seguendo ed ho tempi stretti per finire il lavoro quindi per il momento ho rimandato questo aspetto.
- Non ho trovato soluzione a questo problema: http://forum.joomla.it/index.php/topic,97309.0.html, quindi un'altra concessionaria non potrebbe utilizzarlo.
- Ho fatto la regisrazione del componente manualmente, per adesso non ho preparato un pacchetto di installazione stndard.
Grazie per l'aiuto, ciao.

76
Joomla! 1.5 / Re:problema componente agenzia immobiliare
« il: 12 Mar 2010, 23:23:23 »
potresti provare cos: fai una installazione in locale e ci carichi il template. Poi prendi la cartella del template e la carichi sullo spazio web usando un trasferimento ftp. Potresti addirittura ridenominare la cartella in locale prima di trasferirla: cos, invece di sovrascrivere il preesistente, ti troveresti con un template in pi. Una volta verificato che tutto ok potresti poi passare alla cancellazione del vecchio.

77
Joomla! 1.5 / Re:xmap e contenuti non linkati a men
« il: 12 Mar 2010, 22:53:41 »
non capisco perch mi prendi in giro... Se per CREARE si intende scrivere tutto di proprio pugno, beh... L'ho creato io. Visto che sono un neofita (di joomla e del web, mica della programmazione!) non s ancora creare un plugin che faccia quello che mi serve... Con qualche dritta sicuramente potrei farcela, con del sarcasmo andr ben poco lontano. Spero di aver frainteso il tuo tono.

78
Joomla! 1.5 / xmap e contenuti non linkati a men
« il: 12 Mar 2010, 13:53:35 »
Ho creato un componente per joomla che gestisce l'autosalone di una concessionaria.
Xmap inserisce correttamente la voce "vetrina" che la lista dei veicoli e che ho aggiunto al men del sito, ma non mette l'elenco delle pagine con la descrizione dei singoli veicoli.
Queste pagine naturalmente non sono collegate direttamente a men, ma sono accessibili dalla lista veicoli che f campo alla voce "vetrina".
Qualcuno conosce un modo per includere nella site map questo tipo di contenuti ?

79
Ok, non preoccuparti. Per il momento ho trovato una soluzione momentanea, ci penser pi avanti.

Comunque, solo per chiarezza, vorrei precisare che non voglio che il modulo legga i parametri del componente (gi dal primo intervento ho notato che tu la pensi cos).... anche a me quella sembrerebbe una castroneria! Qui si tratta del fatto che il componente viene richiamato dall'esterno (in questo caso il mio modulo) e quindi il punto di men attivo non quello dove sono reperibili i suoi parametri.
Secondo me aveva capito bene mau_develop:
Citazione
Il modulo semplicemente mostra dei veicoli random con il link alla pagina dei dettagli. A quel punto ormai si nel componente e, cliccando sul link al form per richiesta info il componente cerca di reperire l'indirizzo a cui spedire la richiesta dai suoi parametri, ma non possibile perch, arrivando dal modulo, non detto che il punto di men attivo sia quello del componente stesso

Ad ogni modo grazie mille per l'aiuto, sei stato fin troppo paziente.

80
L'indirizzo uno solo ed scritto nei parametri del componente, che uno solo e gestisce dalla lista alla richiesta di info. Nel processo attraverso il componente non ci sono problemi, come mi avete detto becco l'id dalla richiesta ed accedo ai parametri.
Ma passando dal modulo (come hai descritto al punto 3), come prendo i parametri ? L'Itemid non affidabile: il modulo visualizzato in tutti i men!

Pagine: 1 2 3 [4] 5 6 7 ... 10
Host

Torna su