Autore Topic: errore 404 dopo passaggio da locale a remoto  (Letto 260 volte)

Offline vivilpresente

  • Nuovo arrivato
  • *
  • Post: 4
    • Mostra profilo
errore 404 dopo passaggio da locale a remoto
« il: 12 Feb 2019, 14:52:03 »
Ciao a tutti. Premetto che non sono praticissimo.
Dopo aver portato il sito da locale a remoto spunta il famoso errore 404.
Riesco ad accedere al pannello di controllo ma non si visualizza il sito.
Versione joomla 3.9.1
PHP 7.1


Non so se sono nella sezione giusta del sito per chiedere aiuto e mi scuso preventivamente.
AIUTATEMIIIII!

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29796
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:errore 404 dopo passaggio da locale a remoto
« Risposta #1 il: 12 Feb 2019, 14:54:51 »
Ciao e benvenuto nel forum


Servirebbero maggiori informazioni come link al sito e metodo che hai usato per il trasferimento.




NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline vivilpresente

  • Nuovo arrivato
  • *
  • Post: 4
    • Mostra profilo
Re:errore 404 dopo passaggio da locale a remoto
« Risposta #2 il: 12 Feb 2019, 15:28:13 »
ho usato filezilla per trasferire i contenuti. ho estratto il db in locale e l'ho caricato su aruba. ho modificato il file configuration.php inserendo i dati del Database user e pass.
Ho modificato anche.


public $log_path = '/web/htdocs/www.miosito.com/home/logs';
public $tmp_path = '/web/htdocs/www.miosito.com/home/tmp';

Offline tomtomeight

  • Global Moderator
  • Fuori controllo
  • ********
  • Post: 29796
  • Sesso: Maschio
  • Gli automatismi aiutano ma non insegnano nulla.
    • Mostra profilo
    • Xataface Italia
Re:errore 404 dopo passaggio da locale a remoto
« Risposta #3 il: 12 Feb 2019, 15:46:51 »
Magari filezilla ha perso qualch3 file per strada, hai controllato la coda? Prova a ritrasferirli.
NEWS DataGrill Xataface Installer (Ver. 1.0.1) per Joomla 3.8.x - DEMO Gestione Magazzino

Offline emerenziano

  • Esploratore
  • **
  • Post: 89
  • Sesso: Maschio
    • Mostra profilo
Re:errore 404 dopo passaggio da locale a remoto
« Risposta #4 il: 12 Feb 2019, 20:57:50 »
Io cancellerei tutto quanto fatto (file e DB), farei un backup del locale con Akeeba, trasferirei il backup ed il kickstart sul server e quindi restore. Di solito con Akeeba non si hanno problemi.

Offline vivilpresente

  • Nuovo arrivato
  • *
  • Post: 4
    • Mostra profilo
Re:errore 404 dopo passaggio da locale a remoto
« Risposta #5 il: 13 Feb 2019, 22:34:38 »
Grazie dei consigli.
Con filezilla ho provato 3 volte. Riproverò una quarta.
Con akeeba non sono riuscito ad installarlo. Riproverò.
Grazie.

Offline emerenziano

  • Esploratore
  • **
  • Post: 89
  • Sesso: Maschio
    • Mostra profilo
Re:errore 404 dopo passaggio da locale a remoto
« Risposta #6 il: 13 Feb 2019, 23:31:36 »
Potresti essere più specifico: in locale hai usato Xampp o un server su Linux ? Visto che l'errore 404 vuol dire che non ha trovato una pagina potrebbe trattarsi di un problema di permessi ai file o cartelle che sono gestiti in modo differente da Windows e da Linux.
Per Akeeba, che problema hai avuto ? Installa in locale la versione core (gratuita), creati un backup con il profilo di default (intero sito, formato JPA, upload kikstart e ANGIE come sript di ripristino).

Poi scarica con Filezilla sul server sia il file .JPA che kickstart.php, poi vai su http://tuosito/kickstart.php e ripristina rispondendo alle semplici domande (dove è il DB, come si chiama, utente, password; poi le altre cose di default).Buon lavoro.

Offline vivilpresente

  • Nuovo arrivato
  • *
  • Post: 4
    • Mostra profilo
Re:errore 404 dopo passaggio da locale a remoto
« Risposta #7 il: 16 Feb 2019, 12:00:44 »
Grazie per i consigli.
In locale ho usato Xampp ed mio host è aruba.
Per akeeba mi ha dato un errore sia nell'installazione del pacchetto sia scompattando e facendo istallazione manuale. Proverò a scaricare un altra versione.
Grazie ancora. Vi aggiorno.

Offline emerenziano

  • Esploratore
  • **
  • Post: 89
  • Sesso: Maschio
    • Mostra profilo
Re:errore 404 dopo passaggio da locale a remoto
« Risposta #8 il: 16 Feb 2019, 13:58:41 »
Se non riesci ad installare Akeeba in locale allora significa che il problema è lì e te lo porti dietro nel passaggio al server dell'hosting.
Eventualmente prova ad installare Admin Tools core (gratuito) e fai il fix dei permessi e poi riparazione ed ottimizzazione delle tabelle del DB.

Poi riprova ad installare Akeeba prelevandolo dal suo sito.
Facci sapere.

 

Host

Torna su