Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Topics - d-force

Pagine: [1] 2 3 4
1
Joomla! 3 / Joomla cancella <span></span>
« il: 13 Nov 2015, 20:29:20 »

Salve a tutti,


ho un modulo html in cui ho scritto:


Codice: [Seleziona]
<h4 class="decorated"><span>Guarda le foto del percorso</span></h4>
tuttavia Joomla non visualizza <span></span>,


infatti se apro il codice sorgente della pagina si vede:
Codice: [Seleziona]
<h4 class="decorated">Guarda le foto del percorso</h4>



Premetto che non uso editor di testo. Inoltre, nel modulo html non cancella <span>, ma solo nel codice sorgente che non si vede.

PS. La cosa curiosa che se al posto di <span> uso <spant>, funziona!  :o

A qualcuno capitato questo problema?


Grazie


d-force

2
Salve a tutti, sto aggiornando due miei siti dalla versione 3.4.3 alla 3.4.4., tuttavia la termine dell'upload ricevo il seguente errore:
 Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at webmaster@***.com to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.




Se poi faccio un refresh della pagina in basso a destra, risulta che la versione stata aggiornata alla 3.4.4.


Secondo voi da cosa pu dipendere questo problema?


Grazie 1000!

3
SEO / Indicizzazione url "bizzarra"
« il: 06 Giu 2015, 18:34:24 »
Salve a tutti,


attraverso lo strumento Webmaster tool di Google, ho rilevato che il bot di Google indicizza le mie url in maniera abbastanza "bizzarra"...


1- indicizza le stesse url sia in versione "dinamica" come http://www.miosito.com/it/prezzi-appartamenti.html?id=0 che "normale"
http://www.miosito.com/it/prezzi-appartamenti.html


2- mixa contenuti e url. Esempio:
questa url:
http://www.miosito.com/it/prezzi-appartamenti/index.php?option=com_content&view=article&id=41&Itemid=151
ha gli stessi identici contenuti di questa:
http://www.miosito.com/it/cosa-fare-in-vacanza-in-toscana/vacanze-enogastronomiche-in-toscana/la-cucina-toscana.html


In quest'ultimo caso, come potete vedere dalla url, la seconda quella giusta. La prima invece un mix di tutto un p... :-[


Nelle impostazioni SEF del pannello di controllo ho settato su SI: Attiva Url Sef, Riscrivi Url Sef, Suffisso Url.
Alias Unicode invece su NO.


Sinceramente non riesco a capire il perch di questa confusione...


Quello per che ho capito che sto subendo una penalizzazione enorme data la grande ridondanza dei dati e dei contenuti duplicati.... lascio a voi immaginare.


Come posso risolvere?


Grazie 1000 anticipatamente










4
Salve a tutti, vi presento il mio sito, fatto con Joomla 3.3.6


www.ridemontaione.com


Questo sito nasce con l'obbiettivo di promuovere il cicloturismo in Toscana, in particolar modo nella zona di Montaione (provincia di Firenze). Si organizzano tour guidati in Mtb e noleggio biciclette.
Inoltre sul sito, vengono presentati i tracciati per mtb e bici da strada scaricabili in diversi formati.


Spero vi piaccia. Consigli e suggerimenti sono ben accetti.


Ciao


d-force

5
Salve a tutti, vorrei abilitare il modulo articoli pi letti nel mio sito.


Si tratta di un sito multilingua con 5 lingue.


Ora vorrei che il modulo "articoli pi letti" considerasse tutti gli articoli pi letti di tutte le lingue...


Mi spiego meglio:


Ad esempio:
pagina "Home - it" letta 20 volte
pagina "Home - en" letta 10 volte
pagina "Home - de" letta 30 volte
pagina "Home - fr" letta 40 volte
pagina "Home - nl" letta 20 volte

Vorrei che il modulo visualizzasse in tutte le lingue che la pagina "Home" stata letta in TOTALE 120 volte, e non 20 volte per la versione IT, 10 per la versione EN, e cos via...

Come si fa ad "unificare" i dati? Forse associando le voci di menu? In questo caso associando la "Home -it" alla "Home -en" e cos via?

PS. Lo stesso discorso dovrebbe valere anche per un modulo di rating che vorrei installare a breve...

Grazie per le vostre delucidazioni

d-force

6
Joomla! 3 / Nome menu: Menu_Item_Root (Alias: root)
« il: 29 Ago 2014, 10:03:32 »
Salve a tutti,


nella gestione dei moduli, in particolare nella sezione in cui si assegna il modulo ad una determinata voce di menu, ho trovato - a fianco del nome del men - la seguente scritta "Menu_Item_Root (Alias: root)".


Per spiegarmi meglio, vi allego uno screenshot.


Qualcosa pu essere andato storto durante l'installazione/migrazione di Joomla?


Grazie per il vostro aiuto!


d-force

[allegato eliminato automaticamente dopo un anno]

7
Salve a tutti,


spero di aver postato nella sezione giusta...


Ho in sito web che mostra una serie di percorsi da fare con la mountain bike o la bici da corsa e vorrei renderlo un p pi "social"...


In pratica per ogni percorso vorrei fare in modo - dopo che l'utente si loggato -che l'utente possa cliccare su un link che dice: "ho fatto questo percorso".


Cliccando, dovrebbe venire aggiunto ad una lista degli utenti che hanno fatto quel percorso.


In pi vorrei che a fianco alla dicitura "ho fatto questo percorso" venisse mostrato il numero degli utenti che hanno fatto quel determinato percorso.
Es. "questo percorso stato fatto da 20 utenti".


Per non farsi mancare nulla,  :D  vorrei inoltre che fosse possibile vedere una lista degli utenti che hanno fatto quel determinato percorso.


Secondo voi, esiste qualcosa per fare questo - componente, plugin o modulo - nella JED o devo affidarmi ad uno sviluppatore?


Grazie anticipatamente per i vostri suggerimenti.


d-force

8
Salve a tutti,


come da titolo vorrei passare da j2.5.24 a j3.3.3 ma senza aggiornare tutto il sito.


Vorrei fare una nuova installazione di j3.3.3 e prendere dal DB di j2.5.24 solamente le tabelle che contengono i contenuti, le voci di men, le categorie e poi importarle nel nuovo DB di j3.3.3.


Cos facendo mi ritroverei una installazione pulita di j3.3.3 con i soli articoli e le voci di men.


Secondo voi possibile?O rischio di avere problemi in quanto le strutture dei due DB sono diverse?


Grazie per le vostre delucidazioni!


d-force


9
Sicurezza / Utenti iscritti senza modulo registrazione
« il: 16 Apr 2014, 14:44:44 »
Salve a tutti,


ultimamente mi capitato di essermi ritrovato un paio di utenti iscritti al mio sito Joomla senza aver mai pubblicato il modulo di registrazione. Ovviamente da pannello di controllo non erano attivati.


Premetto che si tratta di un sito joomla 2.5.19 (ultimo aggiornamento) e che tutte le estensioni sono state aggiornate.


Come possibile che si siano iscritti? Possono aver lasciato dei malware anche se non li ho mai abilitati?


Grazie a tutti per le vostre risposte!


d-force

10
Salve a tutti, dal pannello di amministrazione Joomla, ricevo un errore verifica versione Joomla. (si vede l'icona di divieto di accesso).


Cliccandovi sopra ricevo questo ulteriore messaggio di errore:


500 - Si verificato un errore.
Cannot use a stream transport when "allow_url_fopen" is disabled.


Cosa pu essere successo?

11
SEO / Google ignora il tag Title.
« il: 13 Ott 2013, 21:51:54 »
Salve a tutti, come da titolo Google sembra ignorare il tag title nei risultati di ricerca, nonostante questo sia stato regolarmente settato.


In pratica ho scritto il tag title operando sulla voce di men e poi Opzioni visualizzazione pagina > Titolo pagina Browser: qui ho scritto il tag Title.


Google invece, nei risultati di ricerca, ignora questo tag title e visualizza al suo posto quanto scritto nella voce di men.


Ad esempio per una chiave di ricerca relative alle vacanze in bicicletta, google mi restituisce questo risultato:


Vacanza in Mountain Bike in Toscana (che corrisponde al nome della voce di men) + nome sito


anzich


Vacanze in bicicletta in Toscana, percorsi e sentieri adatti a mountain bike, single tracks e strade panoramiche alla scoperta della campagna e territorio di Montaione. (che corrisponde al tag title)


Come possibile tutto questo?


Ho sbagliato a fare dei settaggi nelle impostazioni generali?


Grazie anticipatamente per il vostro aiuto!


d-force





12

Salve a tutti, qualcuno potrebbe aiutarmi a scrivere un codice di validazione php per validare un campo?




In pratica ho un form (rsform) con diversi campi (nome, cognome, data arrivo, data partenza, ecc...)




Adesso vorrei aggiungere un menu a cascata con i seguenti items:
- nessuno
- Bianco
- Nero




La regola di validazione dovrebbe essere la seguente:




Se scegli Bianco e la data di arrivo compresa tra il 1 novembre e il 30 novembre 2013 e dal 1 aprile al 30 aprile 2014, OK valido.
Se scegli Nero e la data di arrivo compresa tra il 1 novembre e il 30 novembre 2013 e dal 1 aprile al 30 aprile 2014, OK valido.
Se scegli Nessuno e la data di arrivo compresa tra il 1 novembre e il 30 novembre 2013 e dal 1 aprile al 30 aprile 2014, OK valido.


Se invece,






Se scegli Bianco e la data di arrivo NON compresa tra il 1 novembre e il 30 novembre 2013 e dal 1 aprile al 30 aprile 2014, ERRORE.Se scegli Nero e la data di arrivo NON compresa tra il 1 novembre e il 30 novembre 2013 e dal 1 aprile al 30 aprile 2014, ERRORE.
Se scegli Nessuno e la data di arrivo NON compresa tra il 1 novembre e il 30 novembre 2013 e dal 1 aprile al 30 aprile 2014, OK valido.




Qualcuno cos gentile da aiutarmi a scriverlo?




Grazie anticipatamente!

13
SEO / Problema indicizzazione pagine/articoli
« il: 15 Mag 2013, 10:32:03 »
Salve a tutti ho notato che Google indicizza le mie pagine sia come:


- http://www.piedicosta.com/...../index.php?option=com_content&view=article&id=177&Itemid=318


che


- http://www.piedicosta.com/..../prodotti-tipici.html


E' possibile che ci siano dei link errati da qualche parte? Perch fa cos?


Il problema che cos mi ritrovo contenuti duplicati con la conseguente penalizzazione da parte di G.


Come posso verificare il problema e risolverlo?


Grazie e saluti!


d-force

14
Gestione Forum / Visualizzazione forum di default.
« il: 22 Gen 2013, 22:30:20 »
Salve a tutti ho installato l'ultima versione i Kunena forum su Joomla 2.5.8.


Quando si accede al forum viene visualizzata la Tab delle discussioni recenti, mentre io vorrei che venisse visualizzata la Tab dell'Indice delle Categorie.


E' possibile? (non riesco a trovare questa impostazione dal pannello di controllo...)


Grazie in anticipo per il vostro aiuto!


d-force

15
Salve a tutti,


ho creato un forum con Kunena accessibile solamente ad utenti registrati.


Poi, ho installato il modulo Kunena Latest (che mostra gli ultimi posts) sulla home page del mio sito.


Ora, siccome, la home page del mio sito accessibile a tutti, vorrei che il modulo Kunena Latest fosse visibile anche a chi non registrato in modo da rendere "appetibile" l'iscrizione al forum anche agli utenti non registrati.


E' possibile farlo?


Grazie 1000!


d-force

16

Salve a tutti, seguendo un tutorial trovato in rete, ho costruito un template (per Joomla 2.5) in cui si trova una sezione (in pratica un "div" contenitore largo 1000px) che presenta 5 colonne.


Vedi immagine allegata.


Ognuna delle 5 colonne ha le seguenti caratteristiche:
- Ha assegnato un modulo (es. user1 per la prima colonna, user2 per la seconda colonna, e cos via...).
- E' larga 200px.


Vorrei fare in modo che se un modulo (ad esempio quello in posizione user5) non pubblicato, le altre 4 colonne si auto-ridimensionano fino ad occupare tutto lo spazio del div contenitore di 1000px.


In pratica si allargano da 200px a 250px.


Per fare questo ho utilizzato la propriet "countModules" nel seguente modo:


Prima della dichiarazione del Template ho inserito la funzione che conta i moduli e ri-assegna la larghezza in base a quanti sono pubblicati:
Codice: [Seleziona]
<?php
$nmod 
0;
if (
$this->countModules("user1")) $shelf++;
if (
$this->countModules("user2")) $shelf++;
if (
$this->countModules("user3")) $shelf++;
if (
$this->countModules("user4")) $shelf++;
if (
$this->countModules("user5")) $shelf++;
// se sono pubblicati 5 moduli
if ( $nmod == ) {
  
$modwidth "200px"// ogni modulo sar&agrave; largo il 20%
  // se sono pubblicati 4 moduli
}if ( $nmod == ) {
  
$modwidth "250px"// ogni modulo sar&agrave; largo il 25%%
// se sono pubblicati 3 moduli
}if ( $nmod == ) {
  
$modwidth "333px"// ogni modulo sar&agrave; largo il 33.3%
// se sono pubblicati 2 moduli
}if ( $nmod == ) {
  
$modwidth "500px"// ogni modulo sar&agrave; largo il 50%
} else if ($nmod == 1) { // se &egrave; pubblicato 1 modulo
  
$modwidth "1000px"// il modulo sar&agrave; largo il 100%
}
?>




Poi nel corpo del Template ho inserito questo codice:


Codice: [Seleziona]


<?php if ($this->countModules("user1")||
         
$this->countModules("user2")||
         
$this->countModules("user3")||
         
$this->countModules("user4")||
         
$this->countModules("user5"))  ?>



 
<div id="myshelf">
<!-- Inizio Contenitore principale-->


<?php if ($this->countModules("user1")) {?>
<div id="mod1" style="width:<?php echo $modwidth ?>;" >
       <jdoc:include type="modules" name="user1" style="xtml" /><><?php ?>
<?php if ($this->countModules("user2")) {?>
<div id="mod2" style="width:<?php echo $modwidth ?>;" >
       <jdoc:include type="modules" name="user2" style="xtml" /><><?php ?>
<?php if ($this->countModules("user3")) {?>
<div id="mod3" style="width:<?php echo $modwidth ?>;" >
       <jdoc:include type="modules" name="user3" style="xtml" /><><?php ?>
<?php if ($this->countModules("user4")) {?>
<div id="mod4" style="width:<?php echo $modwidth ?>;" >
       <jdoc:include type="modules" name="user4" style="xtml" /><><?php ?>
 <?php if ($this->countModules("user5")) {?>
<div id="mod4" style="width:<?php echo $modwidth ?>;" >
       <jdoc:include type="modules" name="user5" style="xtml" /><><?php ?>


<><!-- Fine Contenitore principale-->




Nel foglio di stile, definisco i parametri delle varie colonne (ma questo non un problema...):


Codice: [Seleziona]
#myshelf{
width:980px;
height:455px;
margin:auto;
padding:15px 0 0 0;
background-color:#339999;
position:relative;
}


#mod1,#mod2,
#mod3,#mod4{
text-align:left;
width:176px;
float:left;
}


#mod1 .moduletable,#mod2 .moduletable,
#mod3 .moduletable,#mod4 .moduletable{
  text-align:left;
  padding:5px;
  color:#000;
  font-size:1.1em;
}
 
#mod1 .moduletable h3,#mod2 .moduletable h3,
#mod3 .moduletable h3,#mod4 .moduletable h3{
  text-align:left;
  padding-left:5px;
  color:#ff6600;
  font-size:1.3em;
}


Il problema questo:


La funzione che definisce la larghezza dei div ($modwidth) non funziona.


Se apro il sorgente della pagina vedo:


Codice: [Seleziona]
<div id="mod1" style="width:;" >

Dove width non ha nessun valore...


Dove l'errore che non permette al div di allargarsi? ???


Grazie in anticipo per il vostro aiuto!


d-force

[allegato eliminato da un amministratore essendo vecchio pi di un anno]

17
Joomla! 1.6/1.7/2.5 / Come esportare solo contenuti e men?
« il: 23 Mag 2012, 15:17:50 »
Salve a tutti, poich devo fare un test su un sito web, voglio creare un nuovo sito web con gli esatti i contenuti di un altro gi esistente.

Ho quindi bisogno di esportare:

- contenuti (tutti gli articoli)
- categorie
- voci di men (con alias, titolo browser, ecc)

Il resto,moduli, componenti, plugin, ecc... li installo ex-novo.

Sapreste dirmi esattamente quali tabelle devo copiare dal vecchio database MySql?

Grazie 1000! Attendo fiducioso!

18
Sicurezza / Sito attaccato da virus.
« il: 07 Apr 2012, 22:06:46 »
Salve a tutti, il mio sito web stato attaccato da un virus.

Infatti non accessibile da coloro che usano l'antivirus Eset Nod32 in quanto rivela quanto segue:

JS/Iframe.BX trojan

Come posso fare a risolvere?  ???

19
Salve a tutti, poich la mia versione di Joomla 1.7.4 aggiornata a 2.5.1 mi dava qualche problema, ho deciso di fare una nuova installazione di Joomla 2.5.1 e importare il database (quello precedentemente creato dopo aver aggiornato Joomla 1.7.4 a oomla 2.5.1).

Fatto curioso che sono scomparsi dal Pannello di Controllo i due pulsanti: "Joomla aggiornato" e "Tutte le estensioni sono aggiornate".

Come faccio ad ad avere di  nuovo i pulsanti?

Non che mi ritrovo una versione di Joomla 2.5.1...a met?

Grazie 1000!

20
Salve a tutti dopo aver aggiornato con la procedura automatica ho riscontrato i seguenti problemi:


- Cliccando su alcuni link ricevo errore 404 (quando invece il collegamento all'articolo corretto)
- Cliccando su un link vengo rimandato ad un articolo diverso da quello impostato. (Anche qui, ho verificato che il link punta articolo giusto e non a quello a cui vengo rimandato)


Ho notato che questo non avviene se disattivo dalla configurazione globale > impostazioni SEO i seguenti parametri: Attiva Url Sef, Riscrivi Url Sef e Suffisso url.


Altro problema:


Se provo a modificare (da Gestione menu > menu principale) l'articolo a cui punta un link ricevo il seguente errore: JFolder: :folder: Il percorso non una cartella. Percorso:


La cosa curiosa che non lo fa con tutti i links ma solo con alcuni... :-\


Come posso fare a risolvere questi 2 problemi?


Grazie 1000!


d-force

Pagine: [1] 2 3 4
Host

Torna su