Back to top

Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - walturbo

Pagine: [1] 2 3 4 ... 12
1


Ciao a tutti!!!

Sul mio sito di ricette (multilingua ITA-ENG da poco tempo e per adesso solo poche pagine tradotte) accade una cosa strana che mi sta facendo perdere le staffe giÓ da un mese

Questo URL Ŕ legato a un "Tipo di voce di men¨ / Categoria Blog" dove ho selezionato la categoria Ricette (dove risiedono gli articoli che mi interessano) ed un tag Pepe (impostato su pi¨ articoli):

https://www.ricettelastminute.com/pepe

Qui fa vedere infatti la lista delle ricette contenenti il Tag Pepe della categoria Ricette.

Oltre a questa voce di men¨ ne ho create altre sia in italiano che inglese associandole tra loro. Quindi, se vado su /pepe e poi premo sulla bandierina inglese che si trova in fondo al sito dovrebbe indirizzarmi sul link /en/black-pepper ... invece questo non accade! Mi riporta su /en/pumpkin facendomi vedere quindi le ricette che contengono il tag Pumpkin.

A questo punto, se vado in fondo e premo nuovamente sulla bandierina, mi aspetto di essere reindirizzato sull'equivalente in italiano /zucca, invece vado a finire su /patate  e qui si chiude il loop, se premo sulla bandiera italiana va di nuovo su /en/pumpkin e cosi via.

Ho controllato e ricontrollato tutte le voci di men¨, non riesco a trovare errori! Qualcuno saprebbe darmi qualche consiglio? Ho anche fatto un "Rigenera" sulle voci di men¨ sia italiane che in inglese ma non Ŕ cambiato nulla.


Ho pure aperto un issue su GitHub due settimane fa... ma nessuno risponde --> https://github.com/joomla/joomla-cms/issues/28555


In pratica:

Tutte le voci in italiano puntano a /en/pumpkin
Tutte le voci in inglese puntano a /it/patate


Aggiungo che non Ŕ sempre questa la situazione che si verifica, potrebbe puntare anche a voci di men¨ diverse, non ne capisco il legame!



Per chi volesse provare, le attuali voci di men¨ sono:

/cipolle
/en/onions

/patate
/en/potatoes

/pepe
/en/black-pepper

/sale
/en/salt

/zucca
/en/pumpkins



Grazie come sempre!!!

2
Salve a tutti,
qualcuno ha mai spostato tramite override la votazione di un articolo?


Ho creato un override articolo ed ho capito che il plugin per visualizzare le stellette e votare compare grazie al codice

   
Codice: [Seleziona]
<?php echo $this->item->event->afterDisplayTitle?>

Ho dei campi aggiuntivi all'interno dell'articolo e mi piacerebbe far comparire la votazione tra un campo e l'altro... ma se provo a copiare questo codice nel punto esatto in cui voglio che compaia la votazione non accade nulla.

La votazione dalle opzioni articolo Ŕ abilitata e se imposto dalle opzioni del plugin Content Vote Sopra oppure Sotto mi sposta tranquillamente la parte della votazione ma non compare dove la richiamo io!

Chi saprebbe darmi una mano?

Grazie,
Walter

3
Ho risolto ripristinato il file .htaccess preso dall'ultima versione di Joomla! incontaminata e sovrascritto al mio... adesso funziona tutto!


Grazie ;-)
Walter

4
Confermo, dove nel link ci sta la /category/ funziona o comunque restituisce una pagina 404 mentre solo con /recipe/ continua a dare quell'errore!


Grazie del consiglio, evito di farla adesso la prova per non fare castronerie e non andare a nanna con l'ansia, ma domani mattina appena svegliato mi metto subito all'opera sperando ci sia semplicemente un qualcosa di scritto male! Ancora grazie per la pazienza!

5

Invece ho una novitÓ, magari se puoi dammi conferma anche tu! Ho appena ripristinato i link che mi avevi fatto modificare sul componente Redirect... riscrivendoli nuovamente l'url per intero. Ho salvato e provando ad accedere al solito link sta funzionando il redirect! Cosa Ŕ successo? Ho fatto una prova anche con un altro link e funziona pure!

Nulla da fare, rimangio quello che ho scritto, Ŕ tornato a dare i numeri per qualche inspiegabile motivo!

6
Adesso non pi¨, stavo cercando di emulare l'url del componente tramite le espressioni regolari... ma per me Ŕ arabo  ;D


Invece ho una novitÓ, magari se puoi dammi conferma anche tu! Ho appena ripristinato i link che mi avevi fatto modificare sul componente Redirect... riscrivendoli nuovamente l'url per intero. Ho salvato e provando ad accedere al solito link sta funzionando il redirect! Cosa Ŕ successo? Ho fatto una prova anche con un altro link e funziona pure!


Che stregoneria Ŕ questa??  ???

7
Nulla da fare, sempre stesso errore. Ho anche eliminato conologia, svuotato cookies e tutto quello che c'era da fare dal browser.

Non utilizzo nessun altro componente per fare i redirect a parte il file htaccess dove ci sta qualche RewriteCond e RewriteRule che hanno sempre funzionato.

8
Ciao radu e grazie per la risposta! Ecco qui lo screenshot!
Aggiungo che prima della disinstallazione del componente ho provato a disabilitare semplicemente la ricetta con ID 1314 (ma anche altre a campione) e tutto funzionava.
Oggi pomeriggio ho reinstallato il componente (vuoto, senza categorie e ricette) sperando tornassero a funzionare i redirect ma nulla, l'errore persiste. Mi sto disperando  ;D

9
Salve a tutti,

ho disinstallato un componente dal mio sito web, e adesso mi ritrovo a fare i conti con delle vecchie url che non restituiscono neanche un errore 404.


Il componente disinstallato Ŕ Gary's Cookbook e gestiva un ricettario.


I vecchi link erano del tipo


https://www.ricettelastminute.com/component/garyscookbook/recipe/1314


Prima di disinstallare il componente ho preparato tutti i redirect che puntano alle nuove pagine, ad esempio il link qui sopra viene reindirizzato a questo https://www.ricettelastminute.com/primi-piatti/zuppa-di-fagioli-alla-bud-spencer e tutti i redirect (centinaia) funzionavano perfettamente.

Adesso che il componente Ŕ disinstallato, non funziona pi¨ nulla. A dire il vero il link di destinazione viene trasformato in http://www.ricettelastminute.com1314/ non permettendo al browser di trovare il sito. In pratica viene omessa la parte /component/garyscookbook/recipe/ .

Come posso risolvere questo problema? Anche con delle espressioni regolari dentro al file .htaccess rewritecond.

Grazie a chi saprÓ aiutarmi! :-)
Walter

10
Non l'ho fatto solo perchÚ volevo accorciare i tempi, magari era un problema diffuso... ma evidentemente uso solo io il router insieme agli articoli archiviati! :-) Inoltre prima vorrei avere la certezza dell'errore, quindi dovrei riprodurlo su un'installazione pulita...  porta via del tempo! Domani se non ho riscontri faccio dei test cosi ne sar˛ sicuro prima di segnalare su github!


Grazie per il consiglio!

11
Beh, tutto Joomla Ŕ fondamentalmente e costantemente in fase sperimentale :-D ma se non ho capito male dalla versione 3.8 il router system dovrebbe essere stabile, tanto che consigliano di utilizzarlo nei siti di nuova produzione.


Citazione
Because the URLs generated with the new routing system are not 100% compatible with the existing router and its URLs, it is suggested that existing sites do not enable the new system without thoroughly testing their sites in a staging environment and addressing any URL changes. New sites are encouraged to make use of the new system immediately.
Da: https://docs.joomla.org/J3.x:New_Routing_System



Io lo utilizzo ormai da mesi e funziona egregiamente in tutto il sito... parliamo anche di articoli datati, l'unica che non vuole saperne Ŕ quella minuscola sezione di articoli archiviati!

12
Joomla! 3 / Sef su articoli archiviati - Routing non funziona
« il: 01 Ott 2018, 17:38:24 »
Ciao ragazzi!! :-D


Ho archiviato tutti gli articoli di una categoria.


Ho collegato un nuovo tasto di men¨ alla categoria in modo da poter visualizzare la lista degli articoli tramite il classico filtro di Joomla ma... i friendly links sono andati a quel paese: premendo su un articolo il risultato Ŕ un link sporco! Come risolvo il problema? Il resto del sito va alla grande, utilizzo il routing!


Questo Ŕ il link degli articoli archiviati: https://www.ricettelastminute.com/top100


Grazie per le eventuali risposte  :D

13
Salve a tutta la community!!


Come da titolo, ho bisogno di capire come inserire i campi aggiuntivi all'interno di un layout in modo che da backend la scheda Contenuto in pratica non venga pi¨ utilizzata. L'utente che andrÓ a scrivere il nuovo articolo da backend lo farÓ solamente dalla nuova scheda creata tramite un gruppo di campi aggiuntivi. Questa richiesta nasce dalla necessitÓ di poter cambiare nel corso del tempo la disposizione degli elementi all'interno dell'articolo e poter replicare l'azione su migliaia di articoli formattati tutti allo stesso modo.


Esempio pratico:


Ho un sito web di ricette. Creo dei nuovi campi aggiuntivi chiamati Foto Ricetta con il nome foto-ricetta, Ingredienti Ricetta con il nome ingredienti-ricetta e Preparazione Ricetta con il nome preparazione-ricetta e li racchiudo dentro un nuovo gruppo di campi aggiuntivi che si chiamerÓ RICETTA. Il layout da richiamare invece si chiamerÓ ricettelayout.php.

Adesso quando creer˛ un nuovo articolo mi ritrovo la scheda RICETTA con i tre campi appena creati all'interno. Li vado a compilare inserendo la foto, gli ingredienti e la procedura ma non vado a scrivere nulla all'interno della scheda Contenuto. Dalla scheda Opzioni vado a richiamare il layout ricettalayout.


A questo punto per visualizzare qualcosa all'interno dell'articolo appena creato devo inserire nel file ricettalayout.php il codice che richiama i tre campi aggiuntivi. Ho provato seguendo questa guida ufficiale ma non riesco a far comparire i singoli campi, anzi, compaiono uno dopo l'altro ma senza darmi la possibilitÓ di cambiarne l'ordine, prende la matrice dove sono salvati i dati e me la stampa, tutto qui!


Sul mio file ho aggiunto alla riga 1 il codice che richiama l'array dei campi aggiuntivi:


Codice: [Seleziona]
<?php
// GET CUSTOM FIELDS
    
$myCustomFields = array();
    foreach(
$this->item->jcfields as $field) {
        
$myCustomFields[$field->name] = $field->value;
    } 
?>


Mentre pi¨ gi¨, dopo il titolo <h2> ho provato a mettere il codice che richiama il valore del singolo campo:



Codice: [Seleziona]
<?php echo $item->jcFields['foto-ricetta']->value?>
<?php echo $item->jcFields['ingredienti-ricetta']->value?>
<?php echo $item->jcFields['preparazione-ricetta']->value?>


Per˛ non funziona, visualizzo solo il titolo dell'articolo e poi pagina bianca  :)


Mentre, se cancello tutto il codice che ho scritto qui sopra ed inserisco dopo l'<h2> solo questo nuovo codice riesco a visualizzare tutti i campi aggiuntivi uno dopo l'altro senza label e senza possibilitÓ di poter applicare css, allinearli e cosi via:


Codice: [Seleziona]
<!-- Load the FieldsHelper -->
<?php JLoader::register('FieldsHelper'JPATH_ADMINISTRATOR '/components/com_fields/helpers/fields.php'); ?>


<?php foreach ($this->item->jcfields as $field) : ?>
   <!-- Render the field using the fields render method -->
   <?php echo FieldsHelper::render($field->context'field.render', array('field' => $field)); ?>
<?php endforeach ?>


Eliminando i codici di sopra ed inserendo solo questo invece vedo sempre tutti i valori dei campi aggiuntivi ammassati ma in aggiunta c'Ŕ il label:


Codice: [Seleziona]
<?php foreach ($this->item->jcfields as $field) : ?>
   <!-- Render the field using the fields render method -->
   <?php echo $field->label ':' $field->value?>
<?php endforeach ?>


Qualcuno ha giÓ affrontato questo problema e saprebbe darmi una dritta?
Quando si hanno migliaia di articoli con una certa disposizione degli elementi e da un giorno all'altro si ha bisogno di cambiare questa disposizione Ŕ alquanto stupido agire da backend aprendo ciascun articolo, ovvio che Ŕ un lavoraccio!! Mentre in questo modo si ha la possibilitÓ di cambiare solo qualche stringa di codice dentro al file di layout ed in pochi minuti si avrÓ la nuova struttura identica per tutte le pagine che richiamano quel layout.


Grazie a quanti vorranno rispondermi, spero di esser stato pi¨ chiaro possibile!!


Walter

14
L'idea dei campi aggiuntivi Ŕ di certo una grande novitÓ... l'avvento di nuovi plugin (a pagamento e non) per ampliare la lista delle tipologie Ŕ anch'essa un'ottima cosa... quello che mi preoccupa invece al momento Ŕ quello che accade quando effettuiamo una ricerca  ;D


15
Joomla! 3 / Consiglio su redirect 302 - 307
« il: 14 Lug 2017, 12:58:17 »
Ciao a tutti, ancora una volta chiedo supporto  ;D

Come alcuni di voi giÓ sapranno, gestisco un sito web di ricette ed utilizzo un componente gratuito ormai precario (anche se in realtÓ viene aggiornato ma molto di rado... comunque un buon 60% delle funzioni fornite non le utilizzo, quindi voglio eliminarlo!).

Con l'avvento dei campi aggiuntivi mi Ŕ balenata in testa un'idea sicuramente ottima, ma che porterÓ via probabilmente qualche anno della mia vita tra tempo e salute: l'idea consiste nel trasferire tutte le ricette in articoli semplici da compilare da backend grazie sempre ai campi aggiuntivi. L'unico problema al momento Ŕ quello che facevo presente qualche settimana fa ma anche qui, spero venga preso in considerazione dagli sviluppatori.

Tutte le ricette del mio sito hanno una certa struttura che io cercher˛ di ricreare tramite gli articoli, qualcosa ovviamente non sarÓ uguale, cambierÓ un po' il template e verranno aggiunte anche delle informazioni in pi¨ per ciascuna scheda-ricetta. Forse qualcosa andrÓ via... in sostanza la nuova scheda non sarÓ identica alla vecchia scheda ma simile... diciamo al 90%.

Le schede attuali hanno questo link:

miosito/ricette/79-primi-piatti/1418-pasta-con-pesto-di-insalata

/ricette/ Ŕ una voce di men¨ del componente che punta alla lista delle categorie

/79-primi-piatti/ Ŕ una categoria del componente

/1418-pasta-con-pesto-di-insalata Ŕ una ricetta


Traslando tutto come fossero articoli la struttura del link verrebbe modificata ad esempio in:

miosito/ricette/primi-piatti/1-pasta-con-pesto-di-insalata

/ricette/
Ŕ una voce di men¨ questa volta collegata ad una lista di categoria articoli

/primi-piatti/ Ŕ una categoria articoli

/1-pasta-con-pesto-di-insalata Ŕ un articolo vero e proprio ma con id sicuramente diverso

Fin qui dovrebbe essere tutto chiaro. A questo punto il problema sarÓ il redirect dal vecchio link al nuovo cercando di perdere meno indicizzazione possibile, anche se haimÚ le schede non saranno identiche, ma questo non sarÓ una grande penalizzazione.

Adesso veniamo alla vera domanda: nel primo caso il men¨ che punta alla lista di categorie con alias ricette (/ricette/) viene fornito dal componente che gestische attualmente le ricette, adesso invece la stessa voce di men¨ con il medesimo alias dovrÓ puntare alla lista di categorie articoli... il problema Ŕ che tutti e due gli alias non possono coesistere ma Ŕ anche vero che per poterci lavorare "pian piano" devo averli entrambi attivi cosi da mantenere le vecchie ricette ancora non traslate in articoli ma nel contempo dare in pasto agli spider le nuove ricette tramite redirect.

Parliamo di quasi 1500 ricette quindi il lavoro Ŕ molto lungo. Non saprei come automatizzare il processo, anzi, direi proprio che Ŕ impossibile perchŔ molti parametri che sul componente sono campi di testo (Es. Ricetta Dietetica: SI) adesso con i campi aggiuntivi saranno variabili booleane.

Secondo voi quale potrebbe essere la soluzione pi¨ adatta per procedere al redirect verso il nuovo link visto e considerato che due alias nella stessa voce di men¨, ma di componenti diversi, non possono coesistere?

Potrebbe essere un'idea quella di cambiare alias all'attuale voce di men¨ da /ricette/ a /ricette-web/ ad esempio in modo da poter usare il nuovo alias ricette con il componente articoli? Per˛ dovr˛ fare i conti con la perdita di indicizzazione e man mano che trasferisco le ricette in articoli andrebbe fatto un redirect 301 anche tramite il componente Redirect.

Un'altra idea potrebbe essere quella di lasciare tutto intatto e creare una nuova voce di men¨ con alias /ricette-provv/ (provvisoriamente nascosta) dove mettere le nuove categorie e ricette tramite il componente articoli. Man mano che completo di copiare le schede tramite il componente Redirect appiopper˛ un redirect 307 finchŔ non avr˛ trasferito le 1500 ricette. Una volta trasferite tutte il vecchio componente verrÓ abbandonato, l'alias nascosto da /ricette-provv/ diventerÓ /ricette/ e tutti i vecchi redirect 307 li trasformer˛ in 301 permanenti.

Scusate se mi sono dilungato... ma volevo esporre questo problema che a primo acchito sembra banale... ma in realtÓ difficile da gestire vista la mole di link che si rischia di veder partire da zero sui motori di ricerca... e dopo quasi 9 anni di lavoro assiduo non sarÓ di certo il massimo!  ;)

16
Ciao a tutti!
Vediamo se qualcuno saprÓ aiutarmi visto che mi sono incartato :-)

Ho creato una voce di men¨ ed il tipo Ŕ "Lista di tutte le categorie". Adesso voglio cambiare il layout di visualizzazione quindi ho creato un override dei file default.php e default_items.php presi dal percorso  /components/com_content/views/categories/tmpl ed incollati su miotemplate/html/com_content/categories e fin qui funziona tutto alla perfezione, provando a modificare i file copiati riesco a vedere le modifiche.

Il problema, alquanto scomodo, si verifica quando devo creare una nuova voce di men¨ identica ma con un layout diverso: purtroppo sembra non esserci la possibilitÓ di scegliere quale layout applicare e quindi impostarne uno diverso per ciascuna voce di men¨... tutte le voci di menu "Lista di tutte le categorie" avranno lo stesso layout modificato tramite override.
L'unica possibilitÓ che si avvicina a quello che vorrei fare io Ŕ la voce Stile template che per˛ mi permette, come dice la stessa voce, di scegliere il template tra quelli default di Joomla e quelli caricati da me... quindi dovrei duplicare il template con non so quali conseguenze... mi sembra dispersivo e non so neppure se alla fine funziona come dico io!

C'Ŕ qualche soluzione a riguardo? Oppure sbaglio qualcosa?

Come sempre... grazie!

17
Ciao a tutti,
solo per segnalarvi una T di troppo nella frase:

Questo sito Ŕ impostato come sito multilingua. Il modulo menu che visualizza la voce di menut Home con lingua impostata su "Tutte" non dovrebbe essere pubblicato.

E se proprio vogliamo essere pignoli, manca il punto finale nella frase:

Questo sito Ŕ impostato come sito multilingua. Mancano una o pi¨ Homepage predefinite per le lingue Contenuti pubblicate sebbene il plugin Language Filter sia abilitato E/O uno o pi¨ moduli Lingua siano pubblicati

Ciao e grazie! :-)
           

18
L'ho segnalato io quel bug e mi hanno anche risposto in maniera poco cordiale... ma va bÚ! In realtÓ non Ŕ un bug ma una mancanza da parte di chi ha scritto il codice proprio perchŔ mancano materialmente i campi per aggiungere ALT e TITLE, non sono previsti. Questa del "leggi tutto" non la sapevo, non avevo mai provato ma tra qualche istante lo far˛, Ŕ importante anche per me!

Un altra cosa che non funziona, a mio avviso importantissima, Ŕ l'ordine dei campi aggiuntivi. Li avevo creati in ordine, erano una decina. Poi mi sono accorto di aver dimenticato un campo text, l'ho creato e spostato dove mi interessava. Fatto questo, sulla gestione dei campi vedo l'ordine corretto mentre nella scheda con i campi dentro l'articolo mi ha sballato tutto... e non c'Ŕ verso di dargli un ordine, mi ha invertito tutto dall'ultimo creato al primo.

Walter

19
oppure l'esperimento potrebbe essere, aggiungere anche un campo testo sotto al campo immagine e dargli come titolo ad esempio: ALT immagine.
Poi con l'override inserire il valore di questo campo testo nel tag del campo immagine   :)

Ciao Alex,
sto provando solo adesso a riprodurre il tuo "esperimento" per˛ ho un intoppo, vediamo se tu o altri saprete aiutarmi!

Ho preso il plugin da /plugins/fields/media/tmpl/media.php e l'ho ricopiato dentro a /templates/il mio template/html/plg_fields_media/media.php. L'override del plugin funziona.

Ho creato il campo media per l'immagine ed il campo text per l'ALT.

Il mio problema adesso Ŕ richiamare all'interno del plugin esattamente quel campo ALT che nel mio caso si chiama {field 10}:

Codice: [Seleziona]
$buffer .= '<img src="' . htmlentities($path) . '"' . $class . ' alt="ALT Immagine"/>';
Vi ringrazio in anticipo!
Walter

20
A questo punto la domanda Ŕ se esiste un tool per verificare la struttura di due database e che evidenzi le differenze in modo da poterle integrare manualmente! Mettiamo da una parte il DB originale e pulito di Joomla! e dall'altra parte il nostro attuale... verifichiamo e correggiamo sperando siano poche o nulle le modifiche da apportare. Non so se conoscete WinMerge, ci vorrebbe qualcosa di simile ma pi¨ specifico. Pi¨ tardi mi metto alla ricerca, se trovo qualcosa di sensato vi terr˛ aggiornati!

Comunque io non riscontro nessun problema sui miei siti, quindi se il DB non Ŕ allineato Ŕ evidente che ci˛ che utilizzo su Joomla non Ŕ stato toccato da queste modifiche, almeno sembra.

Pagine: [1] 2 3 4 ... 12


Web Design Bolzano Kreatif