Visualizza post

Questa sezione ti permette di visualizzare tutti i post inviati da questo utente. N.B: puoi vedere solo i post relativi alle aree dove hai l'accesso.


Post - eddydesigner

Pagine: [1] 2 3 4
1
esatto però per creare un layout alternativo è necessario prima creare l'override della cartella com_content > article e poi duplicare default.php per ottenere il layout alternativo e poterlo utilizzare.. tutto funziona e tutto gira quello che non mi torna è il perchè andando a settare nelle opzioni generali  come layout alternativo quello creato questo non si veda e continui a funzionare il default... se non andandolo a settare dalla voce di menu o direttamente dall'articolo... la funzionalità in joomla c'è ma a me non funziona.. da qui volevo capire se sto sbagliando io, see c'è un bug o se a qualcuno è già capitato e l'ha risolto... perchè magari mi è sfuggira qualche impostazione.Grazie

2
Ciao a tutti,sto cercando di creare un layout alternativo per gli articoli in un template scritto da me.
Seguendo questa procedura: Sono andato nel backend joomla in ESTENSIONI > TEMPLATE > MIO TEMPLATE... Cliccando sul nome del template nella tab override ho creato un Override della cartella com_content > article nel mio template.E fin qui tutto ok. Sempre nella stessa cartella com_content > article ho creato un duplicato del file default.php denominato dettaglio.php.

Ora sono andato in CONTENUTI > ATICOLI > OPZIONI nella tab "Articoli" ho settato in scegli layout da predefinito a "dettaglio". Per questo articolo non esiste una voce di menu (ci si arriva dalla categoria blog anch'essa overridata).E qui nasce il problema perchè quando vado nel frontend continua a caricarmi il file default.php anziche dettaglio.php.

Ho provato più e più volte ma non funziona proprio..l'unico sistema per farlo funzionare è settare direttamente dall'articolo il layout alternativo..  :-X cosa che non voglio fare perchè non posso pretendere che il cliente per ogni nuovo articolo vada a settare il layout alternativo..
In alternativa funziona anche settando il layout alternativo dalla voce di menu madre dell'articolo categoria blog.
Sto iniziando a pensare che sia un bug.. anche se so (spero) che mi smentirete  8) 
p.s la procedura che ho seguito la si può trovare anche qui
https://www.joomla.it/guide-joomla-3/8454-i-template-layout-alternativi.htmlGrazie a tutte le buone anime che vorranno aiutarmi  :-*

3
Joomladay / Joomla World Conference 2017
« il: 18 Set 2017, 17:32:08 »
Ciao a tutti, qualcuno sa dirmi se i talk saranno tradotti simultaneamente in italiano? Avevo letto qualcosa qui:
https://groups.google.com/forum/#!topic/joomla-world-conference-2017/1vMd95sllzw ma è da confermare.


Grazie 1000!

4
Joomla! 3 / Re:Visualizzare modulo in base al dispositivo
« il: 16 Nov 2016, 16:44:43 »
Utilizzo il T3 Framework che utilizza bootstrap


Ciao! Premesso che non conosco bene il framework T3 perchè preferisco disegnarmi e svilupparmi i template da solo..  puoi provare così:
Crei due moduli nella stessa posizione, tra le proprietà del modulo metti queste classi in quello che vuoi venga mostrato su smartphone: hidden-sm hidden-md hidden-lg mentre nel modulo che vuoi venga mostrato su desktop e tablet metti: hidden-xs

d'ho cmq per scontato che il framework che utilizzi usi boostrap dalla versione 3 in su e che tu abbia nel modulo un campo per aggiungere delle classi personalizzate.

Ci sarebbe a mio avviso anche un altro sistema.. molto più complicato: nella index del template utilizzando la proprietà user agent con php individui il dispositivo in uso e fai caricare una posizione modulo piuttosto che un'altra in base alle tue specifiche esigenze.

5
Joomla! 3 / Re:Visualizzare modulo in base al dispositivo
« il: 13 Nov 2016, 19:39:10 »
Ciao Neowar, puoi modificare il template aggiungendo una nuova posizione modulo, e tramite css utilizzando le media query puoi far apparire un modulo solo nei dispositivi desktop e l'altro solo nei dispositivi mobili.
Domanda utilizzi bootstrap nel template? se si quale versione?

6
Joomla! 3 / Re:Aggiornamento "Risolto"
« il: 26 Feb 2015, 22:21:04 »
Perfetto! Mi  sono fatto coraggio e ho uppato la 3.4.0 manualmente via ftp e funziona tutto perfettamente!! ;) ;D

7
Joomla! 3 / Re:Aggiornamento
« il: 25 Feb 2015, 23:09:54 »
Stesso identico problema durante l'aggiornamento automatico qualcosa sembra essere andato storto mi ha dato un errore ed ho terminato l'operazione, il frontend sembra funzionare perfettamente, così come il backend se non fosse che andando nella configurazione globale mi da errore: 500 JHtmlBehavior::formvalidator not found. :(

... sono tentato di caricare via ftp tutti i file di una versione pulita joomla 3.4.0 ma credo che il problema sia più a livello del database.
Ho provato invano a vuotare la cache di joomla sia per le estensioni che per gli aggiornamenti.


Qualcuno sa come risolvere?Grazie


p.s.  Il template l'ho costruito io da foglio bianco.. le estensioni che ho installato sono chronoform5, rockcandy (free), Acymailing (free). ho il bckp di ieri ma non quello di oggi  :'( :'( :'(

9
Ciao a tutti! Sono un assiduo lettore di questo forum, ma questa volta non sono riuscito a trovare la risoluzione al mio problema.. perciò mi sono deciso a scrivere  :D

Allora lavorando alla costruzione di un nuovo sito joomla 2.5 in multilingua  (sono attive tre lingue ita-en-de), che funziona benissimo, mi sono accorto però che al contrario di tutte le altre voci di menu per la predefinita del sito non aggiunge la classe "active" all'elemento della lista.

Digitando www.nomesito.it si viene reindirizzati a www.nomesito.it/it e la voce di menu home non ha la classe "active"

Se invece manualmente scrivo www.nomesito.it/it/home (dove home è l'alias della voce predefinita in menu principale) magicamente viene aggiunta la classe "active" all'elemento


Ovvio che io abbia anche attivato i tre menu (menu ita menu eng menu de) con tanto di bandierina per le tre rispettive home.

A tal proposito richiamando le home manualmente:

www.nomesito.it/it/home-it
www.nomesito.it/en/home-en
www.nomesito.it/de/home-de

(dove home-it, home-en, home-de sono gli alias delle tre home)

in nessuno dei tre casi alla voce home viene aggiunta la classe "active".


Altra prova ho richiamato manualmente le tre home così

www.nomesito.it/it/home
www.nomesito.it/en/home
www.nomesito.it/de/home

ed in questo caso a tutte e tre le pagine viene assegnata la classe "active"  :o

In sintesi joomla una volta attivato il multilingua richiama sempre l'alias della home del menu principale..

Il fatto è che anzichè scrivere

www.nomesito.it/codicelingua/home scrive => www.nomesito.it/codicelingua/  >:( >:( :-[

che non genera la classe "active".

Avete qualche idea su come bypassare questo problema/bug?

Magari con un redirect 301 oppure andando a modificare qualcosa nel core.

Thanks in advance  :)

10
Seguendo il tuo consiglio ho fatto un test su una istallazione pulita di joomla 2.5.4 e virtuemart 2.06 e purtroppo la mia tesi non cambia!!!

Modificando o cancellando la foto del padre scompaiono nel frontend i figli e nel backend scompaiono solo le foto....

ho aperto un post anche su virtuemart.net per segnalare la cosa nella speranza che trovino presto una soluzione.. anche se ci credo poco nel frattempo sono costretto a buttare nel cesso 10 giorni di lavoro e lavorare con joomla 1.5 e virtuemart 1 !!

Maledetto il giorno in cui ho deciso di fare sto sito con la 2  >:( >:( >:(

Per chi vuole seguire la discussione riporto il link:

http://forum.virtuemart.net/index.php?topic=103052.0

11
Gestione e-commerce / [VM 2.0.6] BUG BUG BUG PRODOTTI FIGLI
« il: 23 Mag 2012, 18:59:42 »
Colto dalla disperazione apro questo post per cercare conforto/soluzione.. mi accontenterei del primo!
Incredibile ma vero udite udite!!!

Nel mio aggiornatissimo virtuemart 2.0.6. Ho un prodotto con 9 figli.
Se elimino la foto del prodotto padre scompaiono nel frontend tutti i prodotti figli, e dal backend tutte le foto di tutti i figli.. sistematicametne succede sempre!!! Testato e ritestato aiutooooooooooooooooo >:(

Grosso ma grosso BUG!!

12
Come da titolo sto cercando di creare/modificare la vista che mostra la lista delle categorie mettendo sotto a oguna di essa i relativi prodotti.

views/categories/default.php

... sono riuscito a far apparire la descrizione sotto ad ogni sottocategoria, ma non riesco a far apparire i prodotti...

l'albero della pagina che sto cercando di fare è questo:

Categoria A
- sottocategoria A1(con titolo e descrizione)
   - tutti i prodotti A1
- sottocategoria A2 (con titolo e descrizione)
   - tutti i prodotti A2
- sottocategoria A3 (con titolo e descrizione)
   - tutti i prodotti A3
- sottocategoria A4 (con titolo e descrizione)
   - tutti i prodotti A4
- sottocategoria A5 (con titolo e descrizione)
   - tutti i prodotti A5

13
che VERGOGNA :-[ :-[ :-[

e ci ho aperto pure un post!! perdono... mannaggia l'inglese!!!

GRazie infinite c'avrei potuto perdere anche mezza giornata dietro sta cosa.

14
Ciao a tutti,

sto cercando di inserire nel mio template un default_login.php modificato ma l'override non funziona..

Ho inserito il file modificato nella directory

tempates/miotemplate/html/com_user/login/default_login.php

per fare l'override di questo file:

/components/com_users/views/login/tmpl/default_login.php

perchè non me lo sostituisce? >:( >:( >:( >:( >:( >:( >:( >:( >:(

Possibile che devo andare a modificare il file del core di joomla?  :o
Poi al prossimo aggiornamento che faccio? >:(

Grazie anticipatamente a quanti vorrano intervenire  :)

15
in realtà su:

 sito --> configurazione globale ---> Impostazioni sito

come "livello di accesso predefinito" bisogna lasciare public, perchè quello è il livello di accesso di defalut che assegna joomla nella creazione di un nuovo contenuto quindi di default meglio che sia public.. (altrimenti quando si crea un nuovo articolo menu, modulo etc questo non sarà visibile ai registrati)

per invece fare in modo che chi entra nel sito da visitatore abbia livello di accesso Esterni andare in

Utenti --> Gestione utenti --> Opzioni(in alto a dx)

scheda componente ---(voce) Gruppo utenti per visitatori.. selezionare Esterni

Era solo una precisazione per chiunque si ritrovi ad avere questa necessità..

GRAZIE INFINITE FABRIZIO PER LA DRITTA!!
p.s. mi hai risparmiato decine di righe di if nell'index del template :) :) :) ;D ;D ;D

16
Ciao, mi trovo ad avere la stessa esigenza... ho seguito passo passo i consigli ma il rusiltato è che gli articoli messi come livello di acesso Esterni non li vede neanche l'utente visitatore.. dove sbaglio?

Ricapitolando.. ho creato un gruppo di utenti Esterni, sotto a public e creato un rispettivo livello di accesso poi in configurazione sito -- impostazioni ho settatno come predefinito esterni..

ma nn va.. help!!


17
Joomla! 1.6/1.7/2.5 / Re:[1.7] Modulo a pubblicazione ciclica
« il: 15 Dic 2011, 10:26:36 »
Ciao Giovi e grazie per avermi risposto..

non gestendo direttamente io il sito dovrei fare in modo che questi settaggi possano essere imposati in fase di modifica del modulo quindi avere una cosa "futuristica tipo questa":




18
Joomla! 1.6/1.7/2.5 / [1.7] Modulo a pubblicazione ciclica
« il: 14 Dic 2011, 18:44:38 »
Ciao a tutti,

come da titolo dovrei pubblicare spubblicare un modulo in maniera programmata per più cicli....

Attualmente in joomla all'interno di un modulo possiamo impostare la data di pubblicazione e la data di scadenza...

quello che invece a me servirebbe è poter.. (utilizzando sempre lo stesso modulo) programmare multiple pubblicazioni scadenze.

Non so se mi sono spiegato bene, provo a fare un esempio:

Supponiamo di avere un modulo qualsiasi. Vorrei che questo venisse pubblicato il giorno 20 alle ore 15.00 e che scada alle ore 16, poi alle ore 19 venga ripubblicato e scada alle 22, poi che rivenga pubblicato il giorno 24 alle 15 e scada alle 19.. e così via per una ventina di cicli.

Sapete indicarmi una strada, un plugin? A qualcuno di voi è gia capitato?

Grazie 1000!  ;D ;D

19
Una volta in fase di modifica della voce di menu prices prova a togliere tutte le associazioni che hai fatto. L'associazione va fatta solamente sulle voci di menu della lingua principale..

20
esatto infatti è così.. ma quello è risolto dal fatto che ho anche un menu principale uk dove dentro c'è una voce home predefinita.. come spiegato nella guida.. Grazie 1000!

Spero che questi post possano essere compresi e servire a qualcun altro che abbia il mio stesso problema  :) ;)

Pagine: [1] 2 3 4
Host

Torna su